Vasiliy aka Br0ziliy (br0ziliy) wrote,
Vasiliy aka Br0ziliy
br0ziliy

Category:

Achievement unlocked

Я джва года ждал эту игру ...

Screenshot from 2014-11-27 23:43:51



На самом деле IPv6 мой провайдер раздаёт "с рождения" - только счас руки дошли допилить это дело у себя дома.
Итак. Интернеты у меня раздаёт MikroTik c RouterOS 5.26.

Исходные данные от провайдера:

Váš IPv6 prefix: xxxx:xxxx:xxxx:89f9::/64
Ukončení 6in4 (SIT) tunelu: 5.6.7.8 (то есть удалённый конец 6to4 туннеля)
Vaše strana 6in4 (SIT) tunelu: 1.2.3.4 (соответственно, наша сторона)
IPv6 DNS: 2001:4cc8:0:4:0:5:0:1, 2001:4cc8:0:4:0:6:0:1 (резолверы - не пригготиилос)

1.2.3.4 - кроме прочего это мой "внешний" адрес.

После часика гугления взлетело всё с таким конфигом на роутере:

/interface 6to4 add comment=netbox6 disabled=no local-address=1.2.3.4 mtu=1280 remote-address=5.6.7.8 name=sit1
/ipv6 address add address=xxx:xxx:xxx:89f9::1/64 interface=bridge-local
/ipv6 route add distance=1 gateway=sit1

Первой командой добавили интерфейс sit1 - это будет наш 6to4 туннель.
Второй командой на bridge-local добавили первый возможный адрес из выделеного нам блока.
Третьей командой добавили маршрут "по-умолчанию" для протокола IPv6 (по сути - завернули весь IPv6 трафик в туннель, на той стороне разберутся).
bridge-local у меня обьединяет интерфейс wlan1 и порт ether2-master-local.

На ноуте (Fedora 20) всё поднялось само:

$ ip a l wlan0
3: wlan0: BROADCAST,MULTICAST,UP,LOWER_UP mtu 1500 qdisc mq state UP group default qlen 1000
link/ether aa:bb:cc:dd:ee:aa brd ff:ff:ff:ff:ff:ff
inet 10.10.10.101/24 brd 10.10.10.255 scope global dynamic wlan0
valid_lft 249968sec preferred_lft 249968sec
inet6 xxxx:xxxx:xxxx:89f9:2677:3ff:fea3:587c/64 scope global noprefixroute dynamic
valid_lft 2591682sec preferred_lft 604482sec
inet6 fe80::xxxx:xxx:xxxx:587c/64 scope link
valid_lft forever preferred_lft forever
$ ping6 ipv6.google.com -c1
PING ipv6.google.com(2a00:1450:400c:c04::8b) 56 data bytes
64 bytes from 2a00:1450:400c:c04::8b: icmp_seq=1 ttl=49 time=30.2 ms

--- ipv6.google.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 30.216/30.216/30.216/0.000 ms


Со второй командой конфига роутера проковырялся дольше всего - добавление IPv6 адреса на wlan1/ether1-gateway/sit1 ничего не давало - с вайфай клиентов пинги на ipv6.google.com упорно не ходили.
Заработало только вот так.
Пишу и думаю что я не совсем вкуриваю почему оно живёт только с таким конфигом, и почему не нужно вешать IPv6 адрес на wlan1/ether1-gateway или sit - надо бы пойти про бриджи sit почитать ещё, да и про IPv6. Или мож в каментах кто подскажет?
К слову, провайдер на странице с настройками IPv6 советует Линух настраивать так:

Ukázková konfigurace pro Linux

ip tu add netbox6 mode sit local 1.2.3.4 remote 5.6.7.8 ttl 64
ip li set mtu 1280 dev netbox6
ip li set up dev netbox6
ip ad ad xxxx:xxxx:xxxx:89f9::1/64 dev netbox6
ip ro add ::/0 dev netbox6


То есть айпишник таки добавляется на туннель.
Ну ладно, это они роутят только xxxx:xxxx:xxxx:89f9::/64 ко мне - понятно.
Непонятно вот что - bridge-local нифига не знает про наш 6to4 sit1 туннель, как оно живёт тогда?
А, да - никаких резолверов нигде не прописывал (в resolv.conf - IPv4 адрес МикроТика) - каг оно знает, что ipv6.google.com - это 2a00:1450:400c:c04::8b?

(бля, ну и пиздец же эти IPv6 адреса всё же...)


UPD: воу, воу, палехше...


┌(root)─(server.br0ziliy.org.ua)─(5.45.180.252)─(2.6.32-431.29.2.el6.x86_64)
└(~)
# ssh vk@xxxx:xxxx:xxxx:89f9:xxxx:xxx:xxxx:587c
vk@xxxx:xxxx:xxxx:89f9:xxxx:xxx:xxxx:587c's password:
Last login: Fri Aug 1 18:13:13 2014
┌(vk)─(tramond.local)─(10.10.10.101)─(3.16.4-200.fc20.x86_64)
└(~) -
$

Да они там совсем охуели! Не, я канеш слышал что IPv6 не натится, ибо адресов "хватит усем" - но встречаюсь впервые.
ПС: файрвол накатил уже, самый простой: https://gist.github.com/tiernano/4344701 . Бля, а как его с такими адресами-то менеджить теперь? :(
Tags: ipv6, linux
Subscribe
  • Post a new comment

    Error

    default userpic

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 1 comment